Resolved
The Insights data delays we experienced earlier today have been resolved. All reporting data is now up to date. We apologise for any inconvenience this caused.
Monitoring
We are currently experiencing delays with our Insights reporting. Some data shown in Insights may be stale. We are investigating with our data infrastructure provider and monitoring progress. No action is required on your end. We will update this as we learn more.